Tag Archives: Dell Inspiron

Installing Ubuntu 7.10 (Gutsy Gibbon) on Dell Inspiron 6400

I got hold of Ubuntu 7.10 aka Gutsy Gibbon yesterday. This post will detail the experience of installing it on my Laptop. The computer is a fairly new – about 6 months old Dell Inspiron 6400/E1505 running on an Intel Core 2 Duo T5300 processor at 1.73 GHz, 1 GB RAM, Intel 945 Graphics and a 120 GB hard drive, dual booting with Windows Vista Home Premium and Ubuntu 7.04 (Feisty Fawn).

The steps

Backup critical files
Boot from Live CD
Start Installation
Boot into Ubuntu
Reboot and check if Windows is alive

I wont be dealing with partitioning here since I already have my hard disk partitioned and running Feisty. The partitions are like this 10 GB for / (root) as ext3, 10 GB for /home as ext3 and 1 GB for swap. Another 30 GB as FAT32 for sharing files with Windows Vista. For more information on partitioning refer my earlier post.

Note: The Dell Inspiron 6400 has a 50 MB FAT16 partition. This would raise questions during the installtion of GRUB. If an error message comes up during the installation saying that one of the partitions has inconsistent sectors or allocation units, click Cancel. Do not click Ignore. If there is a second dialog, click Continue.

Boot

The Live CD booted up faster than Feisty and the desktop response was also way better. Wireless networks and wired networks were detected and configured. I began the installation.

Installation

The installer also showed great improvements in speed. I selected the timezone, language, keyboard and then landed at the partition step. I selected to format my root partition and retain my home partition. The advantage of having a home partition is that all customizing and preferences would be retained across all the applications, unlike in Windows where a reinstall would install a set of ‘My’ folders. Installation was complete in 12 minutes. I always hold my breath when the installer reaches the grub installation part. No problems there, even though the Migration Assistant did not detect Windows Vista, GRUB did as it did in Feisty.

Boot into Ubuntu

I restarted the computer after the installtion and booted into Ubuntu. I heard the login sound but saw no splash screen. Either none was used or it appeared for a really short time for me to see it. A new dark wallpaper greeted me but it was still brown :(. CompizFusion was enabled by default but the Compiz settings manager was not installed. I installed it using the command sudo aptitude install compizconfig-settings-manager. I got an array of settings on that one.

I was skeptical if my Intel 945 GMA would handle all those effects. But except that the settings manager which showed some latency in response the effects were in full glory. I will post the screenshots in my next post since I don’t have my laptop with me right now.

Bluetooth is back and worked too. This was one reason where I needed to boot into Windows. I installed the codecs for common audio formats and changed the theme to Clearlooks. The new Clearlooks theme is really good compared to the old one.

Applications

The major ones:

GNOME 2.20
OpenOffice.org 2.3 for Productivity
Mozilla Firfox browser
Pidgin for IM
Evolution for Email

Evolution failed to run :(. I even tried deleting the old .evoltuion folder from my home partition but in vain. It would start and abruptly quit. I tried reinstalling and even that did not help. I use a lot of calendering with email and Thunderbird is not my choice. Evolution displays the tasks and appointments right in the calendar which is very useful. I am not sure what is wrong. Hope an update would fix it soon. Until then its only webmail.

Boot into Windows

I rebooted to check if Windows still made it. Yes it did. It showed up on GRUB and booted well too.

Conclusion

A hassle free install and great improvements. Evolution failure is a big minus and Nautilus sometimes showed signs of slowness. Apart from that I think its a great OS for a casual user. My windows use would now be limited to gaming alone.

Advertisements